An Introduction to RPE 1.2


RPE 1.2 is designed to address many of the usability, reuse and consumability issues of the previous versions. Unlike previous versions the approach we have used in 1.2 is a holistic one that subsumes individual RFEs to major themes, themes that spawn across multiple releases. 

The attached Introduction to RPE 1.2 presentation is, as the name implies, an introduction to the main themes in RPE 1.2 and the individual features that implement them. Please consult the RPE 1.2 Infocenter for details on the individual features described in the presentation.

More to follow.

About these ads

About Dragos Cojocari

Architect for Rational Publishing Engine
This entry was posted in IBM, Rational, Rational Publishing Engine. Bookmark the permalink.

6 Responses to An Introduction to RPE 1.2

  1. Alex says:

    Fantastic work Dragos & team; these improvements are hugely beneficial, and go a long way to addressing the reuse “ceiling” that power users have hit in the past. Bravo!

  2. Cesar says:

    Does RPE1.2 compatible with CLM 4.0.1?

    • RPE 1.2 can generate docs from CLM 4. Do note that when you design templates to be used from within CLM ( or any other product or older RPE versions) you must create templates with version 1. No Rational product currently support version 2 templates.

  3. Ken says:

    Do I understand that correctly — do you mean that if you develop a template in RPE 1.2 it cannot be executed from any Rational CLM GUI (i.e., RRDG) — so using the Launcher is the only option for users to generate reports? Also, we are developing templates in 1.1.2.2 that access 4.0.0.1 CLM applications in addition to 7.1.x legacy tools (ReqPro, CQ, & ClearCase). We are planning to upgrade to CLM 4.0.1 — will our existing templates be upward compatible, or will they need to be re-created (or converted somehow)? Thanks.
    -Ken

    • Correct on both accounts:
      - version 2 templates can only be run from Launcher. If you want to design templates for RRDG use you need to use version 1
      - existing templates work as they are in 1.2 If you edit them in Studio make sure to select version 1 when asled if you want to use them with RRDG

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s