Parallel installations of DOORS 9 clients


Setups consisting of a DOORS 9.6.x client and an older DOORS 9 client installed at the same time on the same machine are not supported by DOORS and will prevent document generation.

The problem is that the DOORS 9.6.x client installer does not does not remove the old version so unless you manually uninstall it yourself you will end up with an unsupported setup. Quoting from Upgrading to a new release of Rational DOORS from an earlier release of version 9:

If you are upgrading to Rational DOORS client version 9.6.1 or later, you must uninstall the previous client by using Windows Control Panel Programs and Features.

This is relevant to  RPE as parallel DOORS 9 installations prevent the DOORS COM API from functioning correctly which in turn  prevent RPE from getting data out of running DOORS instances.

The symptoms range from RPE failing to extract the data to run-time errors as described on the RPE devWorks forum here DOORS 9.6 64 Bit run-time error.

Advertisements

Author: Dragos Cojocari

Architect for Rational Publishing Engine

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s